View unanswered posts | View active topics It is currently Mon Dec 10, 2018 8:21 am



Reply to topic  [ 5 posts ] 
 Server performance issues 
Author Message

Joined: Mon Sep 17, 2018 1:53 pm
Posts: 17
Hi guys,

I am writing about this recent update and that I am not the only person who has experienced this. The server for 2.0 is performing very badly since the update. I have found several other players who have really bad lag in Iterium and can't even write text to other players much like me. As soon as I leave town the game runs great until I find an area with the boosted spawn. Anywhere with the boosted spawn rate is especially prone to really bad lagging. In fact, I think if anybody is hunting at these places it lags the entire server (I cannot confirm this).

On my PC I can run Diablo III, a game with higher performance expectations without lag even when there is a screen completely full of monsters. Perhaps there is something with the algorithm with the fast spawn rate of these creatures and pushing the physical hardware of the server to its limits. Other people playing the game constantly complain about lagging.

What is the issue here? Is it that our processors are being loaded with too many instructions when the RAM could be used to smooth out these issues? Why does a game with much higher hardware requirements run so smoothly on my PC and not this game?


Wed Nov 14, 2018 2:55 am
Profile
Site Admin
User avatar

Joined: Fri Jun 20, 2014 3:48 pm
Posts: 1386
The question is, is the lag coming from the server or is it client side? I did look into it right away and saw that the server was logging some actions out to a debug file, I removed those and updated the server. Check now and see how it is.


Wed Nov 14, 2018 11:27 pm
Profile

Joined: Mon Sep 17, 2018 1:53 pm
Posts: 17
EJ,

Thanks for looking into this, I am about to check out how it runs. I could confirm that lag was not coming from my ISP because I could minimize Xenimus and use my browser without any problems. I'll test it out today and let you know in the evening.

Matt


Thu Nov 15, 2018 6:13 pm
Profile

Joined: Mon Sep 17, 2018 1:53 pm
Posts: 17
I've been playing today and so far I haven't noticed any lag specific to the server. Maybe that issue has been taken care of with your update, but it could be too soon to say. I did notice that for about ten minutes, Iterium was running smoother than usual until after I cleared the spawn at the all stats shrine. I do not know if that had anything to do with it but the town is really laggy again ever since then. I take two steps and lag for a step, and that pattern repeats. Also I sometimes need to type the same message ten times before it appears over my head.

The super spawn at all stats shrine was first causing my computer to lag when I got to room in center just to the left of the female darkwar boss. I am sometimes experiencing lag at Derath's lair outdoors but not often. Another player was saying they were experiencing lag today as well.


Fri Nov 16, 2018 1:55 am
Profile

Joined: Tue Jun 09, 2015 10:50 am
Posts: 568
Location: Huntington Beach, CA
There are lag spikes on x1 prime and pvp as well. Hopefully it gets figured out. Ej mentioned he had an older server running and im assuming with incresed spawn, on 3 servers is quiet taxing.

_________________
Oh, I miss Xencon
Image


Thu Dec 06, 2018 12:49 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.